Daar reken je op .. .

Bestanden samenvoegen

Als er meerdere bestanden zijn die samengevoegd moeten worden is dit een secuur werk. Er zijn wat mogelijkheden om dat te vereenvoudigen.
In onderstaande bijlage heb ik een forrmule gebruikt om telefoonnummers toe te voegen aan een bestaand ander bestand zonder telefoonnummers.

Lees het bestand over de werkwijze.

Excel gedeeltelijk gelijke gegevens samenvoegen

  • Maak een nieuw werkblad aan en kopieer alle gegevens naar dat werkblad.
    Zet de gegevens onder elkaar.
  • Verplaats de telefoonnummers van kolom B naar kolom E
  • Sorteer het bereik A1:E20 op kolom A.
    Onder: Gegevens – Sorteren.
  • Kopieer met de muis nu de telefoonnummers naar de goede adressen.
  • Zet in cel F1 de formule: =ALS($A1=$A2;$E2;$E1)
  • Kopieer de formule naar de andere rijen.
    Het werkblad ziet er nu zo uit. (formules zichtbaar gemaakt)

    (Formules niet meer zichtbaar)
    • Selecteer nu alles en kies voor Kopiëren en vervolgens voor: Plakken spciaal.
    • Hiermee zijn de formules omgezet naar waarden.
    • Sorteer alles nu zo dat de rijen met lege cellen onderaan komen.
    • Verwijder Kolom E geheel.
    • Verwijder alle rijen die in kolom B leeg zijn.
Excel gegevens samenvoegen.pdf
PDF – 579.1 KB 2017 downloads