Daar reken je op .. .

Sorteren verjaardagen

In Excel 2007 is het niet direct mogelijk om datums te sorteren op volgorde van verjaardag. Reden is dat bij een sortering op datum, ook naar het jaar gekeken wordt.

Om een goede sortering te krijgen kunnen er dus extra kolommen worden toegevoegd aan een tabel waarop het wél mogelijk is te sorteren.

Voorbeeldtabel 01:
lo03

  • Hier is een extra kolom C aangemaakt met de kolomnaam mm-dd
  • Zet in Cel C2 de formule: =TEKST(MAAND(B2);"00")&TEKST(DAG(B2);"00")
  • Kopieer de formules naar de overige rijen.
  • In dit voorbeeld zien de formules er dan zo uit:
    lo04
  • De berekening ziet er zo uit:
    lo05
  • Selecteer alle gegevens
  • Kies in het lint menu voor: Gegevens - Sorteren.
    lo06
  • Kies voor een sortering op de naam van de extra kolom mm-dd die is aangemaakt.
  • Zorg dat het vinkje bij 'De gegevens bevatten een koptekst' aan staat.
  • Klik op OK
  • Vervolgens komt de vraag hoe je wilt sorteren. Kies voor 'Alles wat op een getal lijkt, sorteren als getal'.
    lo07
  • De tabel wordt nu netjes gesorteerd.

Voorbeeld 02

  • Maak in de tabel 2 extra kolommen
    1 kolom: Maand
    1 kolom: Dag
  • lo10
  • Zet in cel C2 de formule: =MAAND(B2)
  • Zet in cel D2 de formule: =DAG(B2)
  • Kopieer de formules naar de overige rijen.
  • De formules zien er dan zo uit:
    lo11
  • Selecteer alle gegevens en kies in het lint menu voor: Gegevens - sorteren.
  • Vul als sorteercriteria in:
    Sortering op maand, Waarden, van Klein naar groot.
    [Nieuw niveau toevoegen]
    Soetering op dag, Waarden, van klein naar groot.
  • Met een klik op OK wordt alles gesorteerd.

Voorbeeld 03

Ook met behulp van een extra kolom. (Een variant van Voorbeeld1)

Voorbeeld datums die gesorteerd moeten worden i.v.m. verjaardagen.

  • Zet in een extra kolom (Kolom C in dit voorbeeld) een hulpformule om de sortering mogelijk te maken.
  • Zet in cel C19 de formule  =TEKST(B19;"mmdd")
  • Kopieer de formule naar de overige rijen die gesorteerd moeten worden.
    De formules zien er nu zo uit:
  • Selecteer alle gegevens.
  • Kies in het menu voor: Gegevens - Sorteren.
  • Kies voor Sorteren: Kolom C, Waarden, A naar Z.
    Zorg dat er een vinkje staat bij 'De gegevens bvatten kopteksten'.
  • Klik op OK.
  • Kies in het volgende scherm voor sorteren 'Alles wat op een getal lijkt, sorteren als getal'
  • Klik op OK.
    In beeld komt het resultaat.


SBO Excel Sorteren op maand-Dag.pdf
PDF – 684.2 KB 377 downloads